upgpkg: 2.072.1-1
2.072.1+ dtools - uses non-tagged commit because of important bug fixes tag misses
This commit is contained in:
parent
c8264416a3
commit
e827ef953c
12
PKGBUILD
12
PKGBUILD
@ -1,8 +1,8 @@
|
||||
# Maintainer: Mihails Strasunse <public@dicebot.lv>
|
||||
|
||||
pkgname=('dtools')
|
||||
pkgver=2.071.0
|
||||
pkgrel=2
|
||||
pkgver=2.072.1
|
||||
pkgrel=1
|
||||
pkgdesc="Ancilliary tools for the D programming language"
|
||||
license=("custom")
|
||||
groups=('dlang')
|
||||
@ -12,13 +12,13 @@ makedepends=('dmd' 'libphobos' 'git')
|
||||
depends=('curl')
|
||||
|
||||
source=(
|
||||
"git+http://github.com/D-Programming-Language/tools#tag=v$pkgver"
|
||||
"git+http://github.com/D-Programming-Language/tools#commit=3a32331303e2e62f429b8136ba0de0e9a9294722"
|
||||
"http://www.boost.org/LICENSE_1_0.txt"
|
||||
"autodetect.diff"
|
||||
)
|
||||
sha1sums=('SKIP'
|
||||
'3cba29011be2b9d59f6204d6fa0a386b1b2dbd90'
|
||||
'7fb5bd71d6c4e90c0ca49b292454e11169afdee8')
|
||||
sha256sums=('SKIP'
|
||||
'c9bff75738922193e67fa726fa225535870d2aa1059f91452c411736284ad566'
|
||||
'283f6708499b62b0d2e1429f329f809dc6f2fd659c51e8d3cd0d16ce81efe70d')
|
||||
|
||||
prepare()
|
||||
{
|
||||
|
@ -1,8 +1,8 @@
|
||||
diff --git a/rdmd.d b/rdmd.d
|
||||
index 5d66c9f..61fb86a 100644
|
||||
index bd82637..390d533 100644
|
||||
--- a/rdmd.d
|
||||
+++ b/rdmd.d
|
||||
@@ -51,7 +51,32 @@ else version (LDC)
|
||||
@@ -52,7 +52,32 @@ else version (LDC)
|
||||
else
|
||||
static assert(false, "Unknown compiler");
|
||||
|
||||
@ -18,7 +18,7 @@ index 5d66c9f..61fb86a 100644
|
||||
+ if (!compiler.length)
|
||||
+ {
|
||||
+ import std.process : executeShell;
|
||||
+ auto compilers = [ defaultCompiler, "dmd", "ldmd2", "gdmd2", "ldmd", "gdmd" ];
|
||||
+ auto compilers = [ defaultCompiler, "dmd", "ldmd2", "gdmd2", "ldmd", "gdmd" ];
|
||||
+
|
||||
+ foreach (candidate; compilers)
|
||||
+ {
|
||||
@ -34,9 +34,9 @@ index 5d66c9f..61fb86a 100644
|
||||
+ }
|
||||
+}
|
||||
|
||||
version(unittest) {} else
|
||||
int main(string[] args)
|
||||
{
|
||||
@@ -141,6 +166,8 @@ int main(string[] args)
|
||||
@@ -153,6 +178,8 @@ int main(string[] args)
|
||||
if (bailout) return 0;
|
||||
if (dryRun) chatty = true; // dry-run implies chatty
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user